web-gelistirme-sc.com

Joomla 1.5 PHP7 üzerinde çalışıyor mu?

Sunucumda bir ton sitem var ve Joomla 1.5 ila 3.5 arasında değişiyorlar, ancak şimdi sattığım Joomla 3.5 uzantısı için PHP 7 uyumluluğuna yükseltme yapmam istendi).

1.5 sitesi PHP'nin bu sürümünde çalışır mı?

4
King Products

JSE'de önceki cevabı burada bulabilirsiniz:
PHP Joomla 1.5'in çalışacağı maksimum sürüm nedir?

Ayrıca önerilen minimum PHP 5.3.10, ancak maksimum sürümü değil) listeleyen resmi Joomla Teknik Gereksinimleri vardır.

Kendi tecrübelerime dayanarak, Joomla 1.5 MAX PHP 5.3.29 üzerinde çalışacaktır. Kullanılan uzantılara bağlı olarak, PHP 5.4) , ama yine de PHP 5.3 Joomla'nın bu eski sürümünün kararlı çalışması için Max Sürüm olarak düşünmeyi tercih ediyorum.

Korkarım ki PHP7 üzerinde çalışmayacak.

4
Mikan

PHP 5.6, Joomla 1.5 (kullandığınız uzantılara bağlı olarak) ile gidebileceğiniz kadarıyla ve katı standart uyarı mesajlarını bastırmanız vb.

Barındırma ortamınıza bağlı olarak, Joomla kurulumlarınızın her biri için farklı PHP sürümleri yapılandırabilirsiniz).

Bu, örneğin SiteGround paylaşılan barındırma hesaplarındaki cPanel'deki PHP seçici aracı) ile yapmak oldukça kolaydır.

Diğer ana bilgisayarlarda bu bazen .htaccess dosyasındaki bir yönerge aracılığıyla gerçekleştirilebilir.

4
Neil Robertson